Resolved
eBay Connection Errors

Started
May 10, 2022 at 8:00 AM
Status
Resolved after about 3 hours
Affected
eBay

Impact

Degraded performance
  • Resolved
    May 10, 2022 at 10:47 AM

    We have seen no further issues in the past 30 minutes. All eBay servers appear to be operational again. We will continue to have staff on call and post additional updates if necessary.

  • Monitoring
    May 10, 2022 at 10:09 AM

    eBay has reverted to its old SSL certificates, and the connection problems have cleared up. We are currently monitoring the result.

    All times are in GMT time (US/Pacific is GMT-7).

  • Identified
    May 10, 2022 at 9:02 AM

    We have identified the cause of this incident. eBay is changing their SSL certificates, and we believe they are restarting servers. Bids are being placed from all our geographic locations and being submitted successfully for the most part. Only a handful of snipes have been missed.

  • Investigating
    May 10, 2022 at 8:00 AM

    We are currently investigating this incident.