Scheduled for April 11, 2025 at 4:00 AM – 6:00 AM
Affects
Website
Under maintenance from 4:00 AM to 6:00 AM
Completed
April 11, 2025 at 6:00 AMCompleted
April 11, 2025 at 6:00 AMMaintenance has completed successfully
In progress
April 11, 2025 at 4:00 AMIn progress
April 11, 2025 at 4:00 AMMaintenance is now in progress
Planned
April 11, 2025 at 4:00 AMPlanned
April 11, 2025 at 4:00 AMWe will be performing database maintenance. The maintenance window is expected to last up to 2 hours.
This upgrade is part of our ongoing commitment to ensuring the reliability and performance of our database infrastructure. During this time, the site may be temporarily unavailable.
Important: We do not anticipate any issues with bids being placed during this maintenance period. Our auction bidding systems will remain fully operational throughout.
We appreciate your understanding, and thank you for your continued support.